Probleme mit Update auf neue Version 1.2.0

      Probleme mit Update auf neue Version 1.2.0

      Moin zusammen,

      habe folgendes Problem im Connect Manager, wenn ich auf die neue Version updaten will:

      magento-core/interface_frontend_default_default_blue requires package "magento-core/Interface_Frontend_Default" (version >= 1.1.3, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Interface_Frontend_Default cannot be installed, conflicts with installed packages
      magento-core/Mage_All_Latest requires package "magento-core/Interface_Frontend_Default" (version >= 1.2.0, version <= 1.2.0), installed version is 1.1.5
      magento-core/mage_all_latest requires package "magento-core/Interface_Adminhtml_Default" (version >= 1.1.6, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Interface_Adminhtml_Default cannot be installed, conflicts with installed packages
      magento-core/mage_all_latest requires package "magento-core/Interface_Install_Default" (version >= 1.1.3, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Interface_Install_Default cannot be installed, conflicts with installed packages
      magento-core/interface_adminhtml_default requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.1.8, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/mage_all_latest requires package "magento-core/Mage_Core_Adminhtml" (version >= 1.1.8, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Mage_Core_Adminhtml cannot be installed, conflicts with installed packages
      magento-core/interface_install_default requires package "magento-core/Mage_Core_Modules" (version >= 1.1.7, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/interface_frontend_default requires package "magento-core/Mage_Core_Modules" (version >= 1.1.8, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/mage_core_adminhtml requires package "magento-core/Mage_Core_Modules" (version >= 1.1.8, version <= 1.1.8), downloaded version is 1.2.0
      magento-core/mage_all_latest requires package "magento-core/Mage_Core_Modules" (version >= 1.1.8, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Mage_Core_Modules cannot be installed, conflicts with installed packages
      magento-core/mage_core_modules requires package "magento-core/Lib_Google_Checkout" (version >= 1.1.1, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Lib_Google_Checkout cannot be installed, conflicts with installed packages
      magento-core/mage_core_modules requires package "magento-core/Lib_Js_Mage" (version >= 1.1.3, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Lib_Js_Mage cannot be installed, conflicts with installed packages
      magento-core/mage_core_modules requires package "magento-core/Lib_Varien" (version >= 1.1.3, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Lib_Varien cannot be installed, conflicts with installed packages
      magento-core/lib_varien requires package "magento-core/Lib_ZF" (version >= 1.1.1, version <= 1.2, excluded versions: 1.2), downloaded version is 1.7.2
      magento-core/Lib_ZF cannot be installed, conflicts with installed packages
      magento-core/lib_zf requires package "magento-core/Lib_ZF_Locale" (version >= 1.1.1, version <= 1.2, excluded versions: 1.2), downloaded version is 1.7.2
      magento-core/Lib_ZF_Locale cannot be installed, conflicts with installed packages
      magento-core/mage_all_latest requires package "magento-core/Mage_Downloader" (version >= 1.1.1, version <= 1.2, excluded versions: 1.2), downloaded version is 1.2.0
      magento-core/Mage_Downloader cannot be installed, conflicts with installed packages
      Install Errors
      No valid packages found
      PEAR ERROR: upgrade failed




      Schon komisch. Ich kann mir das gar nicht erklären. Ich gehe davon aus, dass einige Updates sehr wohl durchgeführt wurden und dass die Fehlermeldungen jetzt aufgrund des erneuten Versuchs (ich habe das jetzt bestimmt 5x angestoßen) ausgeworfen werden.

      Was aber auch interessant ist: Ich habe auch das Update des Metapackages angeklickt. Wenn man das tut, dann wird auch das Theme blue aktualisiert, welbst wenn man das gar nicht will. Zumindest hat der Updater das versucht (gleich die erste Fehlermeldung), obwohl ich das Theme selbst ganz bewusst aussen vor gelassen habe.

      Irgendwelche Ideen, woran das liegen könnte (also die Updatefehler) ??? Zur Not spiele ich das Backup wieder auf und versuchs nochmals, aber da funktioniert doch irgendeine Routine im Udateprozess derzeit nicht korrekt, oder?
      Das Problem haben wir gerade gemeinsam gelöst, daher poste ich hier nur die Lösung:

      Es dürfen beim Update nicht alle Pakete ausgewählt werden, sondern nur das "Mage_All_Latest". Dieses aktualisiert gleichzeitig fast alle anderen Pakete, die übrig gebliebenen Pakete lassen sich danach problemlos von Hand aktualisieren.
      Magento Hosting | Cloud Server | Shopware Hosting | Elasticsearch Hosting
      Unsere Hosting-Lösungen nutzen ultraschnelle SSDs und sind jederzeit skalierbar.