Magento Update Version 1.4.0.1 auf 1.7.0.2

      Magento Update Version 1.4.0.1 auf 1.7.0.2

      Guten Morgen,

      wir möchten gerne unsere etwas angestaubte Magento Version auf die Neueste updaten. Auch aufgrund der aktuellen Sicherheitswarnung.

      Nun habe ich schon geschaut, wie man da vorgehen muss. Von anderen CMS bin ich das irgendwie einfacher gewöhnt. Da überschreibt man einfach die kompletten Dateien durch die neuen Dateien. Bei Magento muss man anscheind Schritt für Schritt zur nächsten Version updaten.

      Also von 1.4 auf 1.5, von 1.5 auf 1.6 und von 1.6 auf die 1.7er Version. Ist das richtig so, oder gibt es auch einfachere Wege?

      Und dann haben wir noch ein Problem.

      Wenn ich beim Magento Connect Manager nach neuen Updates suche, dann erhalte ich immer folgende Fehlermeldung:

      Exception caught:


      Warning: Invalid argument supplied for foreach() in /home/tageslic/public_html/downloader/Maged/Model/Pear.php on line 142


      Backtrace:

      #0 /home/tageslic/public_html/downloader/Maged/Model/Pear.php(142): mageCoreErrorHandler(2, 'Invalid argumen...', '/home/tageslic/...', 142, Array) #1 /home/tageslic/public_html/downloader/template/pear/packages.phtml(49): Maged_Model_Pear->getAllPackages() #2 /home/tageslic/public_html/downloader/Maged/View.php(59): include('/home/tageslic/...') #3 /home/tageslic/public_html/downloader/Maged/Controller.php(120): Maged_View->template('pear/packages.p...') #4 /home/tageslic/public_html/downloader/Maged/Controller.php(368): Maged_Controller->pearPackagesAction() #5 /home/tageslic/public_html/downloader/Maged/Controller.php(183): Maged_Controller->dispatch() #6 /home/tageslic/public_html/downloader/index.php(35): Maged_Controller::run() #7 {main}



      Könnt Ihr mir diesbezüglich helfen?

      Beste Grüße
      Manuel