Magento über Magento Connect von 1.5.1.0 auf 1.6.2.0 updaten

      Magento über Magento Connect von 1.5.1.0 auf 1.6.2.0 updaten

      Hallo Rackspeed/Magento-Gemeinde,

      ich habe am Wochenende eine lokale Spiegelung unseres Liveshops erstellt (aktuell Ver. 1.5.1.0) um zu testen, ob ein Update auf Version 1.6.2.0 erfolgreich durchgeführt werden kann.

      Das erstellen dieser Spiegelung war soweit erfolgreich, allerdings ist während dem Updatevorgang über Magento Connect etwas seltsames aufgetreten.

      Hier erstmal meine Vorgehensweise:

      1. Ich habe ein Backup der Datenbank erstellt.

      2. Ich habe den Cache in Magento deaktiviert.

      3. Ich bin in Magento Connect gewechselt und habe erstmal nur Magel_All_Latest auf die neueste Version aktualisiert (ich spreche übrigens nur von Stable Releases). Clear All Sessions and Cache (meine so heißt das) hatte ich auch angehakt.

      4. Nach Schritt 3 und einem Refresh wollte ich dann alle anderen Komponenten aktualisieren. Nur hier ist etwas aufgetreten, was ich mir nicht erklären kann.

      -> Es wurde alles aktualisiert bis auf 5 Komponenten. Mage_Core_Module, JS_Lib_Prototype, das US-Sprachmodule und noch zwei weitere.

      Weder der Versuch die Komponenten im Gesamten zu aktualisieren noch im einzelnen war erfolgreich. Immer kam die Meldung, das bei der Prüfung von Abhängigkeiten festgestellt wurde, das z.B. Mage_Core_Module in Ver. 1.6.2.0 nicht kompatibel zu JS_Lib_Prototype in Ver. 1.6..... ist (da das JS-Modul erst in der Reihenfolge nach Mage_Core stand, war es ja auch noch in der alten Version vorhanden).

      Auch wenn ich JS_Lib_Prototype vorher updaten wollte, um praktisch die Voraussetzung für ein Update des Mage_Core_Module zu schaffen, kam wieder die Meldung, dass das Modul nicht Kompatibel zu Mage_Core_Module 1.5.1.0 war (da ich das ja nicht updaten kann / konnte, ja auch irgendwie nachzuvollziehen).

      Kurzum, es existieren Abhängigkeiten unter den Modulen, wo (zumindest bei mir) bei der Prüfung derer, verhindert wird, das ein Update durchgeführt werden kann, da die Versionen nicht untereinander kompatibel sind.

      Vielleicht ist bei jemanden schon mal so etwas aufgetreten und er kann mir weiterhelfen. Würde mich sehr freuen.

      Grüße

      René