table rates funktioniert nicht

      table rates funktioniert nicht

      ich muss vielleicht etwas knapper fragen :)

      in der tablerates.csv datei steht ja folgendes drin:

      "Land","Region","Postleitzahl","Gewicht (und darüber)","Versandpreis"

      wie kommt das gewicht zum tragen? ich habe es manuell als attribut angelegt und "gewicht" (kleingeschrieben) genannt und zu meinem Produkt "Gutscheinkarte", welches teil eines Bundleproduktes ist, hinzugefügt. Dann habe ich natürlich noch für die Karten die verschiedenen Gewichte vergeben.

      hier noch meine Werte:

      "*","*","*","0.0100","1.4500"
      "*","*","*","0.0050","0.5500"

      ich habe es auch schon ohne Quotes versucht aber gleiches ergebnis.

      der tablerates preis wird aber nicht angezeigt, sondern nur fehlermeldung:
      "Entschuldigung, momentan gibt es keine Angebote für diese Bestellung."

      Wo kann der fehler liegen?
      Also meine CSV sieht fast genauso aus. Habe lediglich die Länder an erster Stelle.

      Meine sieht z.B. so aus:

      Land,"Region","Postleitzahl","Gewicht (und darüber)","Versandpreis"
      AUT,*,*,6.0000,10.7479
      AUT,*,*,2.0000,9.2605
      AUT,*,*,0.0000,7.8571
      DEU,*,*,0.0000,5.9000

      Hast du in der Konfiguration auch die möglichen Länder ausgewählt?
      Mich wunderts, dass man das Gewicht als Attribut überhaupt löschen kann. Mir war so als ginge das gar nicht.

      Aber mir fällt gerade auf, wenn du in deinem Shop gar kein Gewicht mehr nutzt, bei den Versandkosten aber ab einem Gewicht von 0.0050 kg die 55 Cent verlangst, dann kann ja gar keine Versandart angezeigt werden. Weil deine Angebote wiegen ja demnach 0 kg, und dafür hast du in den Tablerates nichts angegeben.

      Änder mal die Zeile:
      "*","*","*","0.0050","0.5500"

      in diese hier:
      "*","*","*","0.0000","0.5500"

      Könnte mir gut vorstellen, dass es daran liegt.
      nee es muss an dem gewicht liegen, weil ich kann es ja nicht mehr bei einem produkt eingeben, ok kann natürlich sein das es nie zu 0 gramm kam, aber das nutzt mir ja an der Wurzel allen übels nichts...

      das gewicht muss mir irgentwie durch eine datenbank operation abhanden gekommen sein. meine vermutung geht dahin durch das löschen der beispiel produkte mit einem script welches ja aber nur die produkte entfernt.

      hab geshen das es ein datenbank reparier werkzeug :) gibt, werd das mal austesten...

      ich hab die zeilen auch mal abgeändert aber nix. in der datenbank steht jetzt folgendes:

      pk website_id dest_country_id dest_region_id dest_zip condition_name condition_value price cost
      13 1 DE 0 package_weight 0.0050 1.4500 0.0000
      14 1 DE 0 package_weight 0.0000 0.5500 0.0000

      max

      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von „maxpayne75“ ()