CSV-Import - SKU nicht angegeben

      CSV-Import - SKU nicht angegeben

      Mal wieder ein Problemchen,

      habe eine original Magento "All Products" aus dem System exportiert und diese anschliessend mit den Daten aus unserem alten Shop gefüllt.

      Alle Tabellen sind original von Magento übernommen aber beim Versuch die CSV wieder zu importieren bekomme ich die Meldung:

      Importzeile übersprungen, Pflichtfeld "sku" nicht angegeben


      Das Feld ist aber da, genau wie alle anderen ..

      Hat jemand Rat ?

      :(
      Ich habe mir deine CSV Datei angeschaut, auf den ersten Blick erscheint diese korrekt.

      Wenn man die Datei allerdings in einem Texteditor öffnet und keinen Excel-Import ausführt, fällt schnell auf, dass die Datei einige "Formfehler" enthält.

      So werden z.B. ", "" und """ Zeichenketten in der Datei im falschen Zusammenhang verwendet. Normalerweise werden mit " und " Zeichenketten umschlossen. Excel kommt mit solchen Dingen zurecht, Magento anscheinend leider nicht. Hinzu kommen einige Fehler im Importprofil selber.

      Du hattest im Profil als Dezimaltrenner und Wertetrenner jeweils ; hinterlegt. Der Dezimaltrenner muss allerdings ein . sein. Umschließe Werte in muss auf " gesetzt werden.

      Die CSV-Datei habe ich wie folgt korrigiert:

      1. Im Texteditor öffnen und mit Suchen & Ersetzen nach einander """, "" und " durch nichts ersetzen bzw. entfernen lassen.
      2. CSV in Excel öffnen und erneut gespeichert: Die Werte müssen mit " umschlossen und durch ; getrennt werden.
      3. Dateiupload über das Magento Backend
      4. Importieren

      Der Import wurde soeben beendet: 1020 Artikel erfolgreich importiert. ;)
      Magento Hosting | Cloud Server | Shopware Hosting | Elasticsearch Hosting
      Unsere Hosting-Lösungen nutzen ultraschnelle SSDs und sind jederzeit skalierbar.
      Was soll ich sagen ... SEHR GEIL :D .. und das an einem Sonntag !! :)

      Auf oben benannte Sachen wär ich gar nicht gekommen, für mich sah die CSV auf den ersten Blick absolut ok aus, aber jetzt wo du mir "auf den Kopf" gestossen hast ist es einleuchtend und klar .

      Jetzt kann ich das wenigstens auf die anderen Listen anwenden, vielen Dank für deine Hilfe und den Service :)
      Ich habe etliche Zeit mit den csv Dateien verbracht, es gibt eine Menge Fehler die man machen kann. So nutzte ich immer UTF-8 kodierung und die Preise dürfen beim import keine "," haben sondern "." Also 2,5€ schreibt sich da drin 2.5. Mein "Lieblingsfehler" ist wenn ich z.B. "sku " schreibe statt "sku". Ein kleines Leerzeichen dort und die gesamte option wird nicht angenommen.

      Falls du probleme hast sag Bescheid, ich habe alle unsere Produkte samt verschiedenen Attributen/Attributsets über .csv importiert.

      Import funktioniert nicht

      rack::SPEED schrieb:

      Ich habe mir deine CSV Datei angeschaut, auf den ersten Blick erscheint diese korrekt.

      Wenn man die Datei allerdings in einem Texteditor öffnet und keinen Excel-Import ausführt, fällt schnell auf, dass die Datei einige "Formfehler" enthält.

      So werden z.B. ", "" und """ Zeichenketten in der Datei im falschen Zusammenhang verwendet. Normalerweise werden mit " und " Zeichenketten umschlossen. Excel kommt mit solchen Dingen zurecht, Magento anscheinend leider nicht. Hinzu kommen einige Fehler im Importprofil selber.

      Du hattest im Profil als Dezimaltrenner und Wertetrenner jeweils ; hinterlegt. Der Dezimaltrenner muss allerdings ein . sein. Umschließe Werte in muss auf " gesetzt werden.

      Die CSV-Datei habe ich wie folgt korrigiert:

      1. Im Texteditor öffnen und mit Suchen & Ersetzen nach einander """, "" und " durch nichts ersetzen bzw. entfernen lassen.
      2. CSV in Excel öffnen und erneut gespeichert: Die Werte müssen mit " umschlossen und durch ; getrennt werden.
      3. Dateiupload über das Magento Backend
      4. Importieren

      Der Import wurde soeben beendet: 1020 Artikel erfolgreich importiert. ;)


      Hallo,
      ich habe diesen Forum Artikel gelesen und alles durchgeführt. Funktioniert bei mir leider nicht. Wahrscheinlich, weil ich was falsch mache.:rolleyes:

      Ich habe die " Zeichen durch nichts ersetzt. In Excel geöffnet und als CSV Datei abgespeichert. Excel machte aber keine "", um den Wert herum. Nur, wenn schon welche in der Tabelle vorhanden sind. Aber dann habe ich doppelte Anführungsstriche.
      Also habe ich das ganze im Editor erstellt und als CSV (UTF 8)abgespeichert.

      Das sieht jetzt so aus:
      "name";"sku";"price";"gewicht";"description";"short_description";"status";"visibility";"tax_class_id";"type"
      "SEPARETT Villa";"90101";"745.0000";"19 kg";"<h3>SEPARETT Villa 9010</h3><p>SEPARETT Villa 9010</p>";"<p>SEPARETT Villa 9010</p>";"Aktiviert";"Katalog, Suche";"Umsatzsteuerpflichtige G&uuml;ter 19%";"simple"

      Warum eigentlich mit Semikolon. Kann ich nicht auch ein Komma verwenden?

      Dann gibt es ja bei Magento 1.6.2 die Möglichkeit über Import zu gehen oder über Dataflow Profil.

      Importiere ich direkt über "Import", kommt die Fehlermeldung das er die erforderliche SKU Reihe nicht findet. Die ist aber da?!:cool:
      Gehe ich über Data Profile sagt er, dass ich einen falsche Wert für "type" habe und der Wert "" ein falsches attribute_set ist.

      Hat da jemand eine Idee?
      Gruß
      WDC

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von „WDC“ ()